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Getting Started

Technical Support

Welcome to the instructional manual for the E-Commerce module within the Eagle Business
Management System (EBMS). In the sections following, explanations and examples of the
available features within the E-Commerce Module will be explained. If you need to reach our
staff for further help, contact us using the information below:

EAGI.E

Eagle Business Software
5351 Lincoln Highway, Suite 9
Gap, PA 17527
(717) 442-3247 x2
(717)-442-1096 fax

www.EaqgleBusinessSoftware.com

Email: Support@EagleBusinessSoftware.com

Manual Revision 7.1.213.162 October 2007


http://www.eaglebusinesssoftware.com/

E-Commerce

Introduction

The EBMS e-Commerce module is used to display and sell products on a company website. The

web storeds product w e bn EBMSgand areaupleaded to ethee twebdite wi t h
eliminating the need for experienced web programmers. The module includes a full featured
shopping card that includes terms, shipping options, and pricing uploaded from the EBMS
software. This optional EBMS module facilitates the process of A) Uploading product information,
customer information, and page design from the EBMS Software and B) manage an online
shopping cart, and C) downloading orders from the e-commerce website.

Manage Online Shopping Cart

Upload product
information and Download orders from

customer information e-commerce wabsite
EEMS Software

\ BUSINESS SOFTWARE /

A) Upload information such as product information, customer information, pricing, and
availability.

B) Manage the Shopping Cart

C) Download Orders

The EBMS e-commerce module gives the user the following advantages:

e Add, remove, and control the content of your entire e-commerce website from
the EBMS software. Product pricing, availability, and details are derived from the
EBMS inventory database.

e Add entire groups of products in minutes i Products within the EBMS inventory
catalog can easily be added or removed from the e-commerce store.

e Update product information, pricing, and availability regularly by a simple click of
a button. Products may be removed or marked as out-of-stock based on inventory
levels.

e Reduces redundant information i The user is not required to maintain two separate
product lists; the POS system within EBMS and the e-Commerce list on the web.
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e Dynamic product information is automatically created i New product lists,
customer pricing, and Out of stock notations, details are created directly from the
information within EBMS.

e User specific pricing, terms, and shipping options are displayed based on the
user name and password created within EBMS-A customer 6s price | evel
pricing, terms, and shipping information are derived directly the EBMS software. The
c ust o mene énd passaord are entered within the customer record of EBMS.

e Receive orders directly into your order entry system i E-commerce orders are
inserted into EBMS as a sales order.

e Verify credit card information on-line through a common gateway. Credit card
processing is integrated into the EBMS software. The card is validated on-line but is not
debited until invoice is processed. This feature minimizes the number credits and
billing charges at the time the order is shipped.

Review the following sections for detailed instructions on planning your website, Creating
Inventory Groups, and processing orders.
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System options must be setup before EBMS can connect to the e-commerce website. Go to File
> System Options using the main EBMS menu and click on the Website tab as shown below:

B System Options D_q

Settings | Zip Codes | Country Scanners| WEbSitEl

“website Hostname |www.website.cnm |

EEMS Server | comcast website, com |

‘webszite Username |username | Auto-inzert web orders

‘webzite Password |we|:|'| o345 |

Authorize.net Login 1D |123455?5

Authorize. net AP D |

|
Authorize. net Pags | ahc1274 |
|
|

Authorize.net TS Kep |

[]Uze Autharize.net form

] ] [ Cancel

Enterthee-c o mmer ce websi t évebsitelHBdtnamenentry fietd.h e

The EBMS Server option must contain the address of the Windows server that is running the

EBMS software.  This option is populated only if the orders are automatically downloaded from

the website to EBMS. EBMS must be running on a server running Windows Server or Windows

XP or newer OS to automatically download orders into EBMS. Orders can be entered into

EBMS and be printedinthe user déds office as soon as t hato-order i s
insert web orders option is enabled.

If the orders are manually downloaded to EBMS then select Sales > Download Web Orders
from the EBMS menu to download orders.

The Website Username and Website Password must be obtained from the EBMS e-commerce
server administrator.  This information is required so that EBMS can upload information to the e-
commerce server and download orders from the server.
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The Autorize.net Login ID, Authorize.net Password, and other Authorize.net settings must be
set before any credit card processing is done within the EBMS e-commerce shopping cart on the
web. These entries will remain blank if no credit card processing is done on the web. Review
the Configuring the Shopping Cart > Payment Options section for more details on these settings.
Instructions to apply for an Authorize.net account are found in the Certifications and Applications
> Authorize.Net Application section.

Go to Sales > Options > Website to view or set the website options shown below:

5 (ptions
General Ihwoices and 5.0.3 Devices Fropozal Reparts Salez Person tMeszages
Cusztomer Folders ‘website Barcode Scanner Remate Settings Report Mezzage
\web Cash Account | 01000000 - Cash - Gap v VIS4 Discaver

Master Card  [_] American Express
“Web Customer. WEBSITE

Custorner Matching: {580 ETFalals ZE5 hd [] Create new custamer if no match

Show newiconfor qg daws after Entre Date

Web Groups
Group MHew
FRARY
[ OF. ][ Cancel ]

The Web Cash Account should be set to the general ledger cash account used for website
sales. E-commerce sales paid using a credit card are processed using this cash account. This
account should be a separate cash account than the one used within the EBMS Sales module.
Review the Sales > Customer Payments > Cash Accounts section of the main EBMS manual for
more details on the standard sales cash account.

Enable the credit card options for each card type that is accepted in the online shopping cart.
These options must match the credit card merchant accounts listed in the Authorize.net
configuration. Review the Processing Credit Cards section for more details on credit card
processing.

The Web Customer entry is required for customers who can purchase product on-line without a
login name or password.  The generic customer id entered in the Web Customer entry is used
whenever a person submits an order without specifically identifying themselves by logging onto
the site. Review the Creating a Generic Customer section for more details on the Web
Customer setting. It is important that the terms, shipping options, and other settings within this
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generic customer are configured before customers place e-commerce orders without a login
process. Review the Customer Login section for more details on allowing or requiring customer
logins.

The Customer Matching options are used to compare the customer information on an order
received from a generic customer (customer that has not logged into the system with a user
name) to the customer database within EBMS.  This allows the order to be entered without
logging in but matched with the customer using either the E-mail Address or Name and
Address.  Set this option to None to manually move orders to existing customer records or
create new customer records. The Customer Matching option is not implacable if the Web
Customer entry is blank.

Enable the Create new customer if no match option if a new customer record should be
created within EBMS if the Customer Matching criterion does not match an existing record.
Review the Creating a Generic Customer section for more details on processing orders from the
generic customer.

The Show New Icon... entry identifies the amount of time a new item is listed on a new items
page of the site or shows a new item star-burst by the new item. Review the Identifying New
Products section for more details on this option.

The EBMS e-commerce module allows the user to setup multiple Web Groups although the
average e-commerce site will only contain a single Web Group. Click on the New button if no
Web Groups exist and enter the group label as shown below:

M 5idd Mew Group

Mew group name:
Frirar
P

Click on the OK button to create a new group. Review the Advanced Features > Multiple Web
Groups section for more details on multiple groups.

Click on the Properties button to set additional shopping cart options:
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Shipping Methods | web Canfirmation E-mail | Store Messages |

Shipping Method
STy
UPS 2nd Day Air AM
IJPS 3 Day Select
UPS Ground

PSS Mext Day Air

[ oK ]I Cancel l

All Shipping Methods must be created within EBMS before they can be selected within the web
group properties. Select Sales > Options from within the EBMS menu and create the Shipping
Methods within the General tab. Review the Sales > Freight and Shipping Charges > Creating
Shipping Methods within the main EBMS documentation for details on Shipping Methods.

After shipping methods have been created within Sales > Options then click the Add button
within the Shipping Methods tab of the web group properties.

B Group Properties lﬁj

Shipping Methods | wheb Confirmation E-mail || Store Messages|

Shipping Method
Customer Pickup | Add
LIPS 2nd Day Air &M
Mg C- A Bl Group Shipping Option
PS5 Ground
LIPS Mext Day Air

Select a shipping option:

[

Cugtomer Fickup
LIPS 2nd Day Air &b
UPS 3 Day Select
UPS Ground

LIPS Mext Dayp Air

[ oK ] [ Cancel ]

Select the shipping option and click OK. Repeat for each shipping method that can be selected
as an option within the web shopping cart. Do not include the shipping options that are not
available for the user to choose for web orders.
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Click on the Web Confirmation E-mail tab.

x]

B Group Properties

Shipping Methods | *eb Confirmation E-mail | Store Meszages

E-mail Receipt

From: |Salex@exhcomputer.cnm

Subiject: |Elrder received - v eshcompuber. com

Mezsage:

Wiebmazter E-mail | jack@eshcomputer. com; Jane@eshcomputer. com |

I ok l ’ Cancel

The settings within this tab are used to configure the order confirmation e-mail that is sent to the
customer after an order is placed on the website.

Enter a company sales e-mail address into the From field. This e-mail address will receive any
responses from the customer if the customer replies to the confirmation e-mail.

Enter an appropriate Subject line for the confirmation e-mail.

Enter a miscellaneous message into the Message entry. This message will appear after the
main order information listing the items purchased and pricing.

Enter the e-mail addresses into the Webmaster E-mail entry to send a CC to internal e-mails.
These webmaster copies can be used to prompt the sales team about a web order. Web orders
can also be queried within EBMS. Review the Processing Orders > Displaying and Printing New
Orders section for more details on listing new orders within the EBMS software.

Click on the Store Messages tab.
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Shipping Methods | web Confirmation E -mai | Store Meszages |

Getting Started

%]

[ Filter irventorn items by query ]

Login Meszage:

Shopping Cart Mezzage:

Thank. you for logging into v, EshComputer.com.  The pricing
for each item will be dizplayed including any dizcountz or price
levels previously negotiated with your account.  Please contact
your zales rep at [123) 1231234 if you have any guestions,

Thank, you for Shopping

at vaw EzhComputer.com. You will receive an
order confirmation via e-mail to confirm this order.

]l Cancel l

The Login Message will appear when a customer logs into the system. This message will not

be displayed if a generic retail user is shopping the site without logging into the website. Review
the Configuring the Shopping Cart > Customer Login for more details on customer logins.

Click OK to save the web group properties.
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Planning Your Website

It is important to plan the product arrangement for an e-commerce website before entering folder
templates and information as well as product organization. The ideal number of groups on a
website is between 6 and 20 although less than 6 or more than 20 can be accommodated.

Each one of these groups may contain subgroups. The arrangement of product groups and web
pages will be directly related to the organization of the inventory folders within EBMS. Subgroups
can vary from a few subgroups to dozens or even an hundred or more if necessary. It is
important to organize products in groups and subgroups that simplify the navigation process of
finding products or groups of products. For example the first level of product groups is shown
below:

a3, Options

General Price Levels Sales Level b anufacturing
Wendor Catalogs YW arehouses Ireventory Folders Ebmsz

2 QT ~ Add Folder

+ |:| Accessaries
(L Books Delete Folder
(L7 Business Farms

I:l Cornputer-Business Organizer
[ Computer-Desktop

[ Computer-Motebaak

[ Discaunts

(L1 Eagle Solutions

[ Hardware

[ Inactive

[ Metworks

[ Peripherals

[ Pocket PCs

[ Printers

[ rental

[ ervice
[ Software

[ T IR [ N PR,

Froperties

Edit Defaultz

1

I O oy B

-

2 O O oy Oy B Oy B

ok

[ Cancel

Since the folders labeled Accessories, Computers, Hardware, Networks, Peripherals, and
Printers are located on the first level of the folder tree, these folders will create the first level of
product options within the e-commerce site as shown below.

11
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A Esh Computer Center. - Computer Hardware, Service, Networking, Software,

File Edit Wiew Fawvorites Tools  Help

\_) @ 4 @ @ x'_:] ; Search "“E:l\_g" Favorites @ [Eg:, ‘“:II,,-.:

Address @ hitbp e @shicom, com/

|
Home [ 5.:':;4 r"*f"‘lMﬂUE"ER CENTER

Products b | Accessaries i
Senices : EDD_HS actlls  Shopping Cart
Business Softvfarie | Business Forms
Mewsletter Computers-Deskiop
Contact Us o | Somputers-Motebook
Hardware hesk
Feaple Er—
. etwiorks
mhopping Cart : Er'S,
About U Feripherals SOrid
out s
S Bl Focket PCs -
o _D =¥ Printers ore.
Site Search Y
| | Shop online now!
| Search !
|
717.442.1080 Visit a Store Business Solutions LEIEFSHJEHTS &
aeh ighlights
sales@eshcom.com
n,i@......,... 1~ - 1 Accounting Software

Notice that not all the folder groups within the EBMS folder list are displayed on the web. This is
based on a Show on Web setting within the folder. The www.EshComputer.com example shown
above has the e-commerce product list menu attached to the Products menu option on the left
side of the site. The product menu is designed for each company to create a navigation menu
that is tailored to the needs of each company.

The Accessories group shown below has subgroups listing the difference accessories while the
sub-group Printer Supplies has yet another level of product groups (folders) for each brand.

12
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General Price Levels Sales Level

b anufactunng

YWendar Catalogs Warehouses [rventory Faolders

Ebms

BT oo ~
= I:l ACcessaries T
(L1 Adaptors
(L7 Cables
(L3 Cleaning Items
(L Disks/Remaovable Drives Cart,
(L k¥ Switches
[ PaperiLabels
=[] Printer Supplies
[:l Zanon
D Epson B
(L3 Hewlett Packard
(220 Irk Refills
[ Lexmark
([ okidata
|:| Receipt Printer Supplies
(L1 Samsung Toner
(L3 Surge Protectors/Power Backups

1

Add Folder
Delete Falder

Propertiez

Edit Defaults

I:l Tapes
(L Books
/771 Business Farms b
] l [ Cancel

The Hardware folder group which is also a level one folder has a number of subfolders with the
3" level folders grouping the type of Hard Drives and Memory. Not all groups may contain sub-
folders. Some of the first and second level folders may contain products while others are

grouped in 3" or 4™ level folders.

13
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a3, Options

General Price Levels Salez Level b anufacturing
Wendor Catalogs warehouses Ireventory Faolders Ebrmnz
(L Eagle Solutions # &dd Folder
=-[_] Hardware
[ Cases/Power Supplies Delete Folder
[ crus _
(L1 Floppy & Removable Drives
=-[_7 Hard Drives
3 External Edit Defaults

(L7 IDE Hard Drives
(£ Mokebook HDD's
[ 5as
[C 5C51 Hard Drives
(L Serial ATA
(L Serial ATA I
[ 10 Cards
=2 Mermary
(L3 Compact Flash
[ oDor
[ DDRz
(L FEDIMMs
([ sDRaM
[ soDIMms
L Modems
Cl Maonitors
(L3 Matherboards o
(L7 Optical Drives
[ Sound Cards
[ Tape Drives

[:l TV Tuners
([ video Cards
D Inactive
([ Metworks w
(] l [ Cancel

The website is a bit easier to navigate if folder groups do not contain both products and sub
folders although the system does allow this flexibility.

The next page includes a chart to assist in planning the inventory structure. List the main product
groups and their sub categories.

14
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Note that the list is meant to be a guide and should not be restrictive.

Inventory Structure

1.

15
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Review the details within the Creating product Groups section to create these product groups on
the web.

After creating product group pages on the web, review the Listing Products section to add
products to the website.

18
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Creating Inventory Groups

It is important to plan the product groups before proceeding with this section. This section will
explain the steps required to create web pages for each product group. The website page
settings are set within the Sales > Options > Inventory Folders tab as shown below.

a3, Options

General Price Levels Salez Level b anufacturing
Wendaor Catalogs Wwarshouzes Irventory Faolders Ebmz
= [ Products A Aidd Folder

o Lo CCessories
[ Books Delete Falder
(L7 Business Forms

[ Computer-Business Organizer Eroperties
[ Computer-Desktop
[ Computer-Motebook
[ Discounts
(L1 Eagle Solutions
[ Hardware
[ Inactive
[ Metworks
[ Peripherals
[ Pocket PCs y
[ Printers
[ rental
[ service

[ Software
[ T T S (S P

1

Edit Defaults

|

o}
e

[ Cancel

Click on the first folder group (example: Accessories) and click on the Properties button. Click
on the Website tab as shown below:

19
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M Folder Properties

General | Maming | “Website |H|:uun|:|ing

Show folder on webszite Thurmbnail

Title: | |

Short |Adaptorz, Cables, Cleaning Itemns, Digks C0'e, Remowvable Drives,
Dezc |Paper, Labels, Printer Suppliesz, Surge Protectors, Tapez, and much
more.

Long
Desc

Detail Image

Template: | fstore/piclizt3ud. azp w

[ ]S ] [ Cancel

The Show folder on website option must be enabled to show this group on the website.

Important note: All parent folders must have the Show folder on website option enabled for the
product group website to show. For example the 3" level folder page will not be displayed on the
web if the 1% or 2™ level folder has the Show folder on website option disabled. This also
includes the root folder labeled Products or Inventory. The root folder normally does not require
any settings except that the Show folder on website option is enabled.

The Title is shown on the top of the web page. If this entry is blank the folder name is used as
the title.

The Short Description is an optional description that is often displayed at the top of the product
page. This description should be limited to a paragraph or a few sentences.

The Long Description may contain additional information and is not limited by the amount of
data. This section may include multiple paragraphs or other product links.  This description is
also an optional entry. Review the Links and Associations section for more details on product
links.

The Template drop down option determines the appearance of the page. A number of template
options are available within the EBMS software. Review the Group Templates section for a list

20
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of standard templates. Custom templates can also be added to display specific information or
customize the web page arrangement.

The Thumbnail and Detail Image entries are graphics or photos that are displayed on the
website and are arranged by the template.  These images should depict the contents of the
folder. Note that many templates display the Thumbnail image of all the subfolders and may not
require any images on the root folder. The Thumbnail image will be created from the Detail
Image if the Thumbnail is required and the Thumbnail is left blank.

For example the following steps were completed to create the following Printers webpage:

1. Goto Inventory > Options and click on the Inventory Folders tab.

44, Options r'5__<|
General | Price Levels | Sales Level | Manufacturing | “endor Catalogs Warehuuses| Ireventony Folders | Ebms
ERE=]rFroducts #dd Folder
|:| Accessaries
([ Books Drelete Folder

|:| Business Farms
|:| Computer-Business Crganizer
[C3 computer-Deskiop -
[C3 computer-Motebook
|:| Discounks
[C3 Eagle Solutions
(£ Hardware
|:| Inactive
(23 Metwarks
(£ Peripherals
[C3 Pocket PCs
|:| Printers
L3 rental
|:| Service
(23 software
(£ special Orders
|:| Training
(£ Usedarranty Inventory
(23 video Surveilance
|:| ‘Warranties
(L] web

Properties

1

[ 1] 8 ] [ Cancel

2. Click on the root folder labeled Products, as shown in the example shown above, and
click on the Properties button. Click on the Website tab to show the following dialog:

21
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I Folder, Properties

X]

3. Click on the Printers folder, Click on the Properties button, and click on the website tab
as shown below:

Gerneral | Maming | “ebsite |Fh:uunu:|ing
[#]i5haw folder on website Thurmbnail

Title: |

Short

Desc

Long

Desc

Detail Image
Template: | Aztore/piclizt3sd. asp v|
[ OF. ] [ Cancel ]

a. Enable the Show folder on website option since it is the root folder. This
step is required so all sub-folders with the Show folder on website option
enabled will be displayed on the web.

b. Set the Template to a template such as /store/piclist3x4.asp. This
template will only be used if the products link is used on the website.
Review the Group Templates section for more template options.

c. Enter a Short Description or Long Description only if general product notes
are desired. No Thumbnail image is required on this dialog. The Detalil
Image is not used at this level unless a template such as the itemList is
used. Review the Group Templates section for more information on group
templates.

d. Click on the OK button to return to the Inventory Folder list.
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I Folder, Properties

Gerneral | Maming | “ebsite |Fh:uunu:|ing

[#]i5haw folder on website Thurmbnail

Title: |
Short |Chooze from a vanety of Samzung and Hewlett Packard printers.
Desc | There are lazerjets, inkjets, dot matris, and multi-function laserjet and

inkjet printers. Meed calar and speed? Check out the calar lazeret

options.
Long
Desc

Detail Image
Template: | Aztore/piclizt3sd. asp w |

[ ak ] [ Cancel

This dialog will require more information than the root folder.

a.

b.

f.

Enable the Show folder on website so the printer page is created.

The Title entry is blank so the system will use the folder label i Printers as
the title.

The Short Description gives the page some more information about the
printers.  This description shows below the title T Printers in the website
page shown in the following page:

If a Long Description would be entered in this dialog, the description would
be displayed below all the Icons.

The template /store/piclist3x4 is selected so that the subgroups will be
displayed with individual Thumbnails from the subfolders rather than the
graphics within the printers dialog shown above. The thumbnails are
displayed 3 wide and up to 4 rows long.

Click the OK button to return to the folder list.

4. The Thumbnail images must be set within the individual subfolders i Fax Machines,
HP Deskjets, HP Laserjet Printers, HP Office Jet Printers, etc. The thumbnails for
this page could also be created by the system if the Detail Image within each subfolder
is properly created. Review the Inserting Graphics into EBMS section for more details
on inserting the Thumbnail or Detail Image graphics.

23
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5. Update the website information by selecting Inventory > Update Website. Review the
Update Website Process section for more details on this step.

6. The following website is created as a result of the setting described above.

Page buttons will appear at the top and bottom of the web page if the number of product groups
is greater than the space on the page. The appearance of the website can be configured using a
variety of options. The flexibility of the EBMS e-commerce engine allows the user to personalize
the shopping cart to match the site.

Planning the relationship between the existing inventory folder arrangement and the product
organization on the e-commerce site is very important. The original inventory grouping within
EBMS may need to be rearranged to fit the desired e-commerce store arrangement. The E-
commerce module may also require the user to create more folders so that a large number of
products are not located within a single folder. Note that items or folders that are not listed on
the web can be ignored when planning the e-commerce product arrangement.

Continue with the Listing Products section for more details on adding items to the product groups.
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